Blogs Blogs

«Back

Default Python in FreeBSD changes from 2.6 to 2.7; problems with upgrade.

If you follow the notes in /usr/ports/UPDATING (and you would be wise to do), you must know that the default Python version in FreeBSD has been changed from 2.6.x to 2.7.x. The upgrade of Python itself is unproblematic; however, you might see errors while running 'cd /usr/ports/lang/python && make upgrade-site-packages' of the type:

/usr/local/bin/g-ir-scanner: not found

These have nothing to do with Python, but rather require you to first upgrade devel/gobject-introspection. After that, 'make upgrade-site-packages' should finish successfully without further problems.

Comments
Trackback URL: